几维资讯> 几维动态

Linux高危漏洞被纰漏,可轻易获取root权限

几维安全 2022-03-25 11:03:29  5574
分享到:


此前,Linux内核发布漏洞补丁,修复了内核5.8及之后版本存在的任意文件覆盖的漏洞 (CVE-2022-0847),该漏洞可导致普通用户本地提权至root特权,因为与之前出现的 DirtyCow (CVE-2016-5195) 漏洞原理类似,该漏洞被命名为 DirtyPipe 。     

Dirty Pipe漏洞是研究人员Max Kellermann披露的,在研究一个破坏其一位客户的Web服务器访问日志的漏洞后发现了这个漏洞。该漏洞影响Linux Kernel 5.8及更高版本,以及Android设备,允许本地用户通过公开可用的漏洞获取root权限

该漏洞编号为CVE-2022-0847,允许非特权用户在只读文件中注入和覆盖数据,包括以root身份运行的SUID进程。作为Dirty Pipe披露的一部分,Kellerman发布了一个概念验证(PoC)漏洞,允许本地用户将自己的数据注入敏感的只读文件中,消除限制或修改配置,以提供比通常更大的访问权限。

安全研究人员Phith0n说明了他们如何利用该漏洞来修改/etc/passwd文件,从而使root用户没有密码。进行此更改后,非特权用户只需执行su root命令即可获得对root帐户的访问权限。

安全研究人员BLASTY也发布了最新的漏洞利用,通过修补/usr/bin/su命令将root shell放置到/tmp/sh中,然后执行脚本,更容易获得root权限。执行后,用户将获得root权限。

从2022年2月20日开始,该漏洞已负责任地向各种Linux维护人员披露,包括Linux内核安全团队和Android安全团队。虽然该漏洞已在Linux内核5.16.11、5.15.25和5.10.102中得到修复,但许多服务器继续运行过时的内核,这使得该漏洞的发布对服务器管理员来说仍是一个重大问题。

此外,由于使用这些漏洞很容易获得root权限,威胁行为者在进行攻击时开始使用该漏洞只是时间问题。恶意软件以前使用过类似的Dirty COW漏洞,尽管它更难利用。

我国大量新发布的安卓 12 手机已经用上了 Linux 内核 5.8 版本及以上,包括搭载骁龙 8 Gen 1、天玑 8000 系列、天玑 9000、Exynos 2200 和谷歌 Tensor 的设备等这些设备可能因此受到影响,

建议安全人员安排检查所使用的 Linux 服务器的内核版本,若是 5.8 以上的版本请尽快升级。至于该漏洞在Android移动终端上的影响,则需要各大手机厂商抓紧发布安全补丁。



分享到:



《安卓应用加密》 《Unity3D手游加密》 《源代码加密》 《移动端的KiwiVM虚拟机》